Spring IDE into eclipse

Today, I tried to install parts of the SpringSource Tool Suite into Eclipse Helios SR1 via update-site.
After finding the right update-site of the STS for version 3.6 of eclipse (namely: http://dist.springsource.com/release/TOOLS/update/e3.6 and http://dist.springsource.com/release/TOOLS/composite/e3.6) and following the installation instructions carefully, I had Spring IDE 2.5.2 successfully integrated.
But after restarting eclipse I was shocked, it seemed that the update-manager broke down…
when opening the update-manager the log gasped out:
An internal error occurred during: Contacting Software Sites. java.lang.NullPointerException…
didn’t sound good. After quite a lot of researching and try and failing, I was very glad to find a bug report, which mentioned that this occurs on updating Spring IDE. Thanks to Christian Dupuis from SpringSource, who provided a workaround yesterday. For some reason a second org.apache.commons.httpclient_3.1.0….jar was shipped and confused eclipse. But after commenting one of them out in „configuration/org.eclipse.equinox.simpleconfigurator/bundles.info“
everything was working well again.
Now I can enjoy my Spring IDE and perhaps you can so, too.
edit: in the meantime Christian Dupuis already delivered a quickly fixed update-archive which makes the file manipulating superfluous… Hell these guys are quite fast!

Kommentare

  1. Thanks for bringing light into darkness. I already guessed it`s kind of classloading-issue which caused eclipse to handicap itself…

  2. Hi Sascha,
    I'm glad you took the time to write this down for others. That's a great help for those being trapped in the same situation and see the nasty NPE.
    Anyways, if you're interested in the root cause of the issue take a look at the following Eclipse bug: https://bugs.eclipse.org/bugs/show_bug.cgi?id=317392
    Regards,
    Christian Dupuis
    --
    Christian Dupuis
    Lead, Development Tools
    SpringSource, a division of VMware
    http://www.springsource.com